操作履歴の確認
操作手順
1. 操作履歴を確認するには
処理を起動すると、データ領域ごとの操作履歴が表示されます。
≪操作履歴の詳細≫
メニューバーの「編集」-「詳細」を選択すると、操作履歴の詳細を確認することができます。
[↑][↓]ボタンで確認する操作履歴を切り替えることができます。
≪操作履歴の絞り込み≫
ツールバーの[絞込]ボタンをクリックすると、「絞り込み条件」画面が表示され、条件を指定して表示する操作履歴を絞り込むことができます。
指定した条件はメイン画面に表示されます。[解除]ボタンをクリックすると、絞り込みを解除することができます。
【絞り込み条件画面】
指定する項目にチェックマークを付けて、設定を行い、[実行]ボタンをクリックします。
-
日付 : 指定した範囲の日付の操作履歴を参照します。コンピュータの現在日付の1年前~現在日付が初期表示されますが、変更も可能です。日付を直接入力するか、ボタンをクリックしてカレンダーから選択します。
-
ユーザーID : 指定したユーザーIDに関する操作履歴のみ参照します。IDを直接入力するか、ボタンをクリックして選択します。
-
処理 : 指定した処理に関する操作履歴のみ参照します。処理名を直接入力するか、ボタンをクリックして選択します。
-
操作種類 : 「開始」「終了」「修正」「作成」「実行」といった指定した操作種類の履歴のみ参照します。指定しない場合は、「※すべて」を選択します。
<処理内容例>
i. 処理の場合 : 「開始」、「終了」
ii. マスターの場合 :
部門[100 総務部]を「作成」
部門[102 人事部]を「修正」
部門[104 庶務部]を「削除」など
iii. データ入力の場合 :
社員[100 千代田太郎]の[個人情報]を「作成」
社員[102 神田三郎]の[社会保険]「修正」
社員[104 新橋花子]を「削除」など
iv. 帳票の場合 :
[XXX(プリンタ名)]に出力 「印刷」
[出力先フォルダパス]に出力「Excel出力」など
-
操作内容 : 指定した文字で操作履歴を絞り込みます。操作種類が対象となり、一部含まれる場合もその内容で絞り込みを行うことができます。
文字は全角128(半角256)文字以内で指定します。 -
コンピュータ : 指定したコンピュータに関する操作履歴のみ参照します。
コンピュータ名を直接入力するか、ボタンをクリックして選択します。
2. 操作履歴のファイルを出力するには
操作履歴をファイル保存したり、操作履歴の汎用データを出力したりします。
(1) 操作履歴をファイル保存する場合は、ツールバーの[ファイル保存]ボタンをクリックします。操作履歴を汎用データ出力する場合は、メニューバーの「編集」-「汎用データ出力」を選択します。
(2) ファイルの保存先とファイル名を指定する画面が表示されますので、指定して[保存]ボタンをクリックします。
保存した操作履歴ファイルは、メニューバーの「ファイル」-「履歴ファイルを開く」を選択することで、データ領域との関連付けを行い、内容を参照することができるようになります。履歴ファイルは表示名称の変更、関連付けの解除を行うことができます。
-
履歴表示名の変更 : 「ファイル」-「表示名の変更」を選択することで、表示名を変更することができます。表示名を全角15(半角30)文字以内で入力して、[変更]ボタンをクリックします。
-
関連付けの解除 : 「ファイル」-「履歴ファイルとの関連付けを解除」を選択することで、使用中のデータ領域と操作履歴ファイルの関連付けを解除することができます。
3. 操作履歴を削除するには
日付を指定して操作履歴を削除します。
(1) メニューバーの「ファイル」-「履歴の削除」を選択します。
(2) 「操作履歴の削除」画面が表示されますので、以下の項目を設定します。
-
削除日 : 指定した日付を含むそれ以前のすべての操作履歴を削除します。
日付を直接入力するか、ボタンをクリックしてカレンダーから選択します。 -
削除対象の操作履歴を外部ファイルに出力する : 削除する操作履歴を外部ファイルとして出力します。
外部ファイルとして出力しておくと、後でメニューバーの「ファイル」-「履歴ファイルを開く」を選択することで、データ領域との関連付けを行い、内容を参照することができます。
(3) 操作履歴を削除する場合は、[実行]ボタンをクリックします。
削除を中止する場合は、[キャンセル]ボタンをクリックします。